I.T. Discussion Community!
-Collapse +Expand
Paradox
Search Paradox Group:

Advanced
-Collapse +Expand Paradox To/From
To/FromCODEGuides
-Collapse +Expand Paradox Store
PRESTWOODSTORE

Prestwood eMagazine

July Edition
Subscribe now! It's Free!
Enter your email:

   ► MB LobbyCorel Paradox / ObjectPAL Coding BoardParadox Setup, Vista, etc. Topic   Print This     

Unable to connect to Paradox table using ODBC

Unable to connect to Paradox table using ODBC in Paradox Setup, Vista, etc. topic (part of our Corel Paradox / ObjectPAL Coding group).

Quick Search: connect   Paradox   Unable connect   Unable connect Paradox   table using  
Yesid.B
-- --

Hi there, I am trying to connect to a Paradox table in PHP using the INTERSOLV ODBC driver provided with Paradox. I am able to connect to the DSN fine but when I try to run a query, I get this error:


Warning: odbc_[e_xec(]) [function.odbc-exec]: SQL error: [INTERSOLV][ODBC Paradox driver][Paradox]Network initialization failed., SQL state S1000 in SQLExecDirect

I have checked my lock files and that my BDE has the correct NET DIR location, which is on our server that houses all of our Paradox tables. I have also tried re-installing Paradox several times. I am able to open the tables from this machine using Paradox with no error so I'm confused as to why this could be happening.

Any help would be much appreciated. Thanks!

 Posted 39 months ago (Thread Starter)
Comment Quote
About Yesid.B -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #16622, 2 replies
Thread Started 4/19/2017 10:04:29 AM
View Counter=1063
Last Reply Posted 4/20/2017 6:00:25 AM)
Location=-- -- 
Joined=47 months ago   MB Posts=4  
Moderator
Steven.G
Myrtle Beach, SC USA

 I can only offer one generic suggestion.. be sure that the path to the files, and the path to the BDE, are EXACTLY the same as the paths used by Paradox.. not different mapping that point to the same place.. EXACTLY the same..

hopefully, others will have more points to offer

Steven Green
Senior Software Engineer
Paradox Support Specialist DOS/WIN

Prestwood IT Solutions
8421 Auburn Blvd, Suite 256, Citrus Heights, CA 95610
Office: 916-726-5675 | Fax: 916-726-5676 | http://www.prestwood.com
 Posted 39 months ago
Comment Quote
About Steven.G -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #16627 (Level 2) and Parent is 16622
Reply Posted 4/20/2017 5:28:47 AM
Location=Myrtle Beach, SC USA 
Joined=46 months ago   MB Posts=377  
Most Recent Post
Yesid.B
-- --

Hi Steven,

Thanks for the answer. I ended up solving the problem. The issue was that I was using Anonymous Authentication for the site on IIS and the user that was being used was a user that did not have appropriate permissions to access the lock file over the network. Hopefully this can help others who might run into this problem. Thanks!

 Posted 39 months ago (Thread Starter)
Comment Quote
About Yesid.B -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #16628 (Level 3) and Parent is 16622
Reply Posted 4/20/2017 5:58:37 AM
Location=-- -- 
Joined=47 months ago   MB Posts=4  

Revive Thread!

Add a comment to revive this old thread and make this archived thread more useful.

Write a Comment...
Full Editor
...
Sign in...

If you are a member, Sign In. Or, you can Create a Free account now.


Anonymous Post (text-only, no HTML):

Enter your name and security key.

Your Name:
Security key = P1165A1
Enter key:
Icon: A Post    Thread    Idea    Important!    Cool    Sad    No    Yes    Includes a Link...   
Thread #16622 Counter
1063
Since 4/19/2017

Follow PrestwoodBoards on: 


©1995-2020 PrestwoodBoards  [Security & Privacy]
Professional IT Services: Coding | Websites | Computer Tech