I.T. Discussion Community!
-Collapse +Expand
Delphi
Search Delphi Group:

Advanced
-Collapse +Expand Delphi To/From
To/FromCODEGuides
-Collapse +Expand Delphi Store
PRESTWOODSTORE

Prestwood eMagazine

September Edition
Subscribe now! It's Free!
Enter your email:

   ► MB LobbyPascal and Delphi Coding BoardDelphi Object PASCAL Topic   Print This     

BDE Configuration

BDE Configuration in Delphi Object PASCAL topic (part of our Pascal and Delphi Coding group).

Quick Search: Configuration   BDE Configuration  
epicurean
 (Inactive)
Saskatoon, SK Canada
So yesterday, all was well, happy happy joy joy. Today...when I try to open up my database program...I get an error, Cannot write to Engine configuration file BDE Error 8453 [$21] [$5]. Same problem when I open BDE Admin - System configuration file not found. System default in use. When I try to recreate the Alias and save the settings, same error, Cannot write to Engine configuration file. So my question is..what happened to the configuration file? I still have the new config file that I created previously, but when I try to apply it to the Alias, same error. I still have the default idapi32.cfg file. But when I try to make a new Alias with that config file, and save it as ParadoxTest (which is the name of the Alias I was using before), it won't let me save. Also will not let me save a newly created .cfg file. Any ideas?

Using Delphi 6 enterprise with paradox 4.0 tables. Windows 98. .pas .dpr etc files on a Novel network drive, .cfg file is on the same network drive in different directory.
 Posted 16 years ago (Thread Starter)
Comment Quote
About epicurean -Collapse +Expand
Visit Profile
Inactive member.
Member does not subscribe to this thread.
Email Not Verified!
Once email is verified, we will review and approve the account.
Web Presence Hidden.
Once above is taken care of, full Profile content will display including back links, about me, my message, custom Profile html, social networking links, message board signature, company profile, etc.

Post ID #9948, 12 replies
Thread Started 10/1/2003 9:33:00 AM
View Counter=18611
Last Reply Posted 7/1/2017 3:40:39 AM)
Location=Saskatoon, SK Canada  
Joined=16 years ago   MB Posts=4  
epicurean
 (Inactive)
Saskatoon, SK Canada

I fixed the problem by uninstalling Delphi and re-installing it. Everything seems to work fine now...but just in case it happens again, I'll try to find out what caused it.

 Posted 16 years ago (Thread Starter)
Comment Quote
About epicurean -Collapse +Expand
Visit Profile
Inactive member.
Member does not subscribe to this thread.
Email Not Verified!
Once email is verified, we will review and approve the account.
Web Presence Hidden.
Once above is taken care of, full Profile content will display including back links, about me, my message, custom Profile html, social networking links, message board signature, company profile, etc.

Post ID #9959 (Level 1.1)  Reply to 9948
Thread Started 10/8/2003 11:24:00 AM
View Counter=2
Location=Saskatoon, SK Canada  
Joined=16 years ago   MB Posts=4  
Moderator
Mike Prestwood
Prestwood IT
Prestwood IT office in Citrus Heights, CA

Your logged in user account doesn't have enough rights. For example, when a computer is newly joined to a domain, it typically does not have full rights to write to it's own hard drive. Lots of ways around this, but the technique we usually use is to add the specific user (more secure) or domain users (less secure but more flexible) to the administrator group of the local computer. You have to log in as a domain admin to do this.

Other reasons are similar in nature: out of space, CFG used by another resource, etc.

You can also try saving the CFG to a folder known to have full rights by this user.

--
Mike Prestwood
Prestwood IT Solutions

 Posted 8 years ago
Comment Quote
About Mike Prestwood -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.
About Mike Prestwood

Mike Prestwood is a drummer, an author, and creator of the PrestwoodBoards online community. He is the President & CEO of Prestwood IT Solutions. Prestwood IT provides Coding, Website, and Computer Tech services. Mike has authored 6 computer books and over 1,200 articles. As a drummer, he maintains play-drums.com and has authored 3 drum books. If you have a project you wish to discuss with Mike, you can send him a private message through his PrestwoodBoards home page or call him 9AM to 4PM PST at 916-726-5675 x205.

Web Presence
Facebook, Prestwood IT Facebook page -- fan page. (Visit Me)
Twitter, Follow Prestwood IT on Twitter. (Visit Me)
LinkedIn, Prestwood IT company page on LinkedIn. (Visit Me)
YouTube, Prestwood IT YouTube Channel (Visit My Channel)
Website, My drum website where I sell my drum books. (http://www.play-drums.com)

Post ID #14669 (Level 2) and Parent is 9948
Reply Posted 7/25/2011 10:55:46 AM
Location=Prestwood IT office in Citrus Heights, CA 
Joined=19 years ago   MB Posts=1410   KB Posts=1805   KB Comments=73   BLOG, Topics=4  
Anonymous Post

what if it happens while logged in as administrator?!

---
Amin
 Posted 8 years ago
Comment Quote

Post ID #14682 (Level 1.1)  Reply to 14669 and Parent is 9948
Thread Started 9/17/2011 9:21:50 AM
Torbjorn.A
Eker�, -- --

While moving to Windows 10, I have come across a serious problem with  BDE.

The BDE Info program points to  files no longer in the system.

Where is this information stored and how can i edit it??

Torbjörn Alm

 
 Posted 49 months ago
Comment Quote
About Torbjorn.A -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #15234 (Level 3) and Parent is 9948
Reply Posted 8/7/2015 2:58:05 PM
Location=Eker�, -- -- 
Joined=49 months ago   MB Posts=2  
Moderator
Mike Prestwood
Prestwood IT
Prestwood IT office in Citrus Heights, CA

Did you upgrade to Windows 10? If so, have you tried uninstalling and reinstalling the BDE? Should only take a few minutes to try that.

Let me know what you find.

--
Mike Prestwood
Prestwood IT Solutions

 Posted 49 months ago
Comment Quote
About Mike Prestwood -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.
About Mike Prestwood

Mike Prestwood is a drummer, an author, and creator of the PrestwoodBoards online community. He is the President & CEO of Prestwood IT Solutions. Prestwood IT provides Coding, Website, and Computer Tech services. Mike has authored 6 computer books and over 1,200 articles. As a drummer, he maintains play-drums.com and has authored 3 drum books. If you have a project you wish to discuss with Mike, you can send him a private message through his PrestwoodBoards home page or call him 9AM to 4PM PST at 916-726-5675 x205.

Web Presence
Facebook, Prestwood IT Facebook page -- fan page. (Visit Me)
Twitter, Follow Prestwood IT on Twitter. (Visit Me)
LinkedIn, Prestwood IT company page on LinkedIn. (Visit Me)
YouTube, Prestwood IT YouTube Channel (Visit My Channel)
Website, My drum website where I sell my drum books. (http://www.play-drums.com)

Post ID #15235 (Level 4) and Parent is 9948
Reply Posted 8/9/2015 11:05:55 AM
Location=Prestwood IT office in Citrus Heights, CA 
Joined=19 years ago   MB Posts=1410   KB Posts=1805   KB Comments=73   BLOG, Topics=4  
owen.moore
Ashburton, -- NZ

I am sorry to say it but I think the days of the bed are almost over. I have started migrating my databases across to MS sq compact edition using the components from devart. It takes a bit of work but is certainly worth it

Owen

 Posted 49 months ago
Comment Quote
About owen.moore -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #15236 (Level 5) and Parent is 9948
Reply Posted 8/9/2015 12:50:32 PM
Location=Ashburton, -- NZ 
Joined=16 years ago   MB Posts=7  
Torbjorn.A
Eker�, -- --

Hi!

Yes, I am upgrading to Windows 10 from 7

Thanks for a quick answer. The problem is that I install the  BDE Seven from Coipus, unaware of BDE32. Probably I first installed a Vista version, which did not work and then the W7  version. They clashed and did not really wwork in this wcomputer. BDE7 works perfect in W7 in 2  other computers.

The BDE path etc. poit to their library, which is removed. I have been seaching in vain for the place where the info program is picking up the BDE Config info.

Torbjörn Alm

 
 Posted 49 months ago
Comment Quote
About Torbjorn.A -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #15237 (Level 6) and Parent is 9948
Reply Posted 8/9/2015 1:25:53 PM
Location=Eker�, -- -- 
Joined=49 months ago   MB Posts=2  
Anonymous Post

awefawefawrggbncvfgn

---
stranded
 Posted 48 months ago
Comment Quote

Post ID #15240 (Level 7) and Parent is 9948
Reply Posted 9/5/2015 10:04:34 AM
Anonymous Post

<script>alert("ddddddddddddd");</script>

---
jackson
 Posted 48 months ago
Comment Quote

Post ID #15241 (Level 8) and Parent is 9948
Reply Posted 9/5/2015 10:05:44 AM
massimo
-- USA

Hi,

after upgrading OS from Win7 to Win 10, I can't upgrade BDE configuration.

I reinstalled Paradox.

I can open BDE Administrator, been set compatibility with XP SP3, but after having set new parameters and click on "Apply", the application doesn't work (I have to stop it from Task Manager).

Thanks.

massimo

 Posted 48 months ago
Comment Quote
About massimo -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #15250 (Level 9) and Parent is 9948
Reply Posted 9/27/2015 2:37:31 AM
Location=-- USA 
Joined=15 years ago   MB Posts=1  
Martijn.G
Hoog-Keppel NL

I recently bought a new W10 computer and want to start programming again. I installed Paradox 11 and now I wanted to install Delphi 5 professional. When it comes to configuring the BDE, the installation seems to freeze. Is it not possable to install Delphi 5 under Windows10?

 Posted 27 months ago
Comment Quote
About Martijn.G -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #16710 (Level 10) and Parent is 9948
Reply Posted 6/5/2017 6:05:06 AM
Location=Hoog-Keppel NL 
Joined=28 months ago   MB Posts=5  
Most Recent Post
Martijn.G
Hoog-Keppel NL

I downloaded de BDE from this site ande tried to re-install D5pro again. During installing I get the message "Uninstaller setup failed to initialize". After installing (closed during configuring bde, when the installation seems to freeze), I start the installation again choosing "register only".

When starting D5pro, I get: Your Just-In-TimeDebugger is currently set to " etc.

After that: Failed to set data for 'debugger'. D5 does not start.

I used d:\borland, instead of c:\program files (x86)

Has anyone a clue? Has anyone D5(pro) working on a W10 computer?

 Posted 26 months ago
Comment Quote
About Martijn.G -Collapse +Expand
Visit Profile
Approved member.
Member subscribes to this thread with a verified email.

Post ID #16771 (Level 11) and Parent is 9948
Reply Posted 7/1/2017 3:29:49 AM
Location=Hoog-Keppel NL 
Joined=28 months ago   MB Posts=5  

Revive Thread!

Add a comment to revive this old thread and make this archived thread more useful.

Write a Comment...
Full Editor
...
Sign in...

If you are a member, Sign In. Or, you can Create a Free account now.


Anonymous Post (text-only, no HTML):

Enter your name and security key.

Your Name:
Security key = P1173A1
Enter key:
Icon: A Post    Thread    Idea    Important!    Cool    Sad    No    Yes    Includes a Link...   
Thread #9948 Counter
18611
Since 4/2/2008

Follow PrestwoodBoards on: 


©1995-2019 PrestwoodBoards  [Security & Privacy]
Professional IT Services: Coding | Websites | Computer Tech