I.T. Discussion Community!
-Collapse +Expand
Paradox
Search Paradox Group:

Advanced
-Collapse +Expand Paradox To/From
To/FromCODEGuides
-Collapse +Expand Paradox Store
PRESTWOODSTORE

Prestwood eMagazine

May Edition
Subscribe now! It's Free!
Enter your email:

   ► MB LobbyCorel Paradox / ObjectPAL Coding Board   Print This    All Groups  

Corel Paradox / ObjectPAL Coding New Activity

Switch to:  New Posts (ALL TYPES)
  


25 Threads:


Thread 25 of 25
Thread Starter  

tmitchell
Using Corel Web Server
Mike's Paradox book has an excellent section in the back on using web servers with Object Pal. Is there more info out there that can explain how to use .HTT files in more detail, possibly more examples?
Posted to MB Topic: Paradox Web Stuff
19 years ago
5 replies. Last post:

Jeff.R3
Does your pc have a firewall or anti-virus app blocking your IP,  PORT or Webservice?
31 hours ago
New Stuff Since Your Last Visit
4141
Hits

Thread 24 of 25
Thread Starter  

Cottage Builder
Passing a variable in an export process
HI folks, I have the following code with a form;             exportASCIIVar(":RSA:Mailing Emails.db",":RSA:Reports\\Temporary Mail List.csv", "\t","\"",False,True), ,             MsgInfo("Well Done","The E Mail List for "+s+" has been updated.") S has been populated before this point, but I would like to replace "Temporary Mail List.csv" with a file name made up of the value of s, plus ".csv" Does anyone have any suggestion?
Posted to MB Topic: ObjectPAL
5 days ago
1 Reply:

Steven.G
s = ":RSA:Reports\\Temporary Mail List.csv" exportASCIIVar(":RSA:Mailing Emails.db",s, "\t","\"",False,True) if that's not what you meant, you'll have to explain differently
46 hours ago
New Stuff Since Your Last Visit
18
Hits

Thread 23 of 25
Thread Starter  

gcorvera
Paradox on Windows Server 2012
We migrated from using a run of the mill Windows XP box as a server to Windows Server 2012; one of the applications we use is a simple 3 table database which stopped working the moment the files were being accessed from the new server. We could see data but trying to add anything would result in a Lock Time Out error. I discovered that if I remove Referential Integrity from the detail table structure, and just assign it through the data model on the form, everything works. Would it be OK to leave it like that? or would it be somehow dangerous for the integrity of the data? Could the problem have come from some setting on the server? The person who installed the server for us doesn't think so but I'm not sure he is as familiar with Windows 2012 Server as I thought. For the time being I will be monitoring the data and checking that nothing is lost. Any suggestions? Thanks
Posted to MB Topic: Paradox Setup, Vista, etc.
59 months ago
11 replies. Last post:

Steven.G
{Too Long!}
20 days ago
Nothing New Since Your Last Visit
3874
Hits

Thread 22 of 25
Thread Starter  

PS_1600
Set Range/Pattern Match
I am working with a PDX8 program which uses Wahl2Wahl's table lookups which work very well. The table lookups do not function correctly on PDX10, the up/down arrows and tab do not work. I am trying to create something similar and combining  set range and locate pattern. I can get either to work but not together. Is there a way to code in such a way that the setRange is the default but the user can also type .. to enable the locate pattern logic? method keyPhysical(var eventInfo KeyEvent), , Var,   s  string, endVar,     doDefault,  ,      s = self.value,      ,      ;PART.setRange( self.value, self.value+"zzz" ),    ,       ignoreCaseInStringCompares(yes),       advancedWildcardsInLocate(Yes) ,       PART.locatePattern("DESC",s),   , endmethod Thanks. Steve
Posted to MB Topic: Paradox Forms
37 days ago
19 replies. Last post:

Jeff.R3
I will take a stab at it, Unfortunately,I am on vacation this week. , send a a few sample records, as well as a rough count on how many records you will be searching. I will use that info to create something. Keep in mind, I have never done this, I only presume that I can do it, AND since I have a similar issue will give it a shot. , Jeff
28 days ago
Nothing New Since Your Last Visit
166
Hits

Thread 21 of 25
Thread Starter  

KBNV
Fonts in Win10 v1809
I just set up Paradox on a new system running the latest ver of Win 10 (1809).  My reports on the new system required a complete revision of the fonts used in the report.  I've been using the same ones for years and the fonts have always migrated to the new system.  This time, however, the fonts are not available in the properties, font drop down for any of the fields in my report.  The fonts are installed in the usual place and are available to the other myriad programs.  I installed Paradox from an X9 disc which I know doesn't make a difference.  I even uninstalled Paradox from the system and reinstalled using the X8 disc in the hope that it would make a difference.  It, of course, did not.  I am using other fonts that provide a similar impact.  But, not the same. Any body have any suggestions? Thanks in advance. Karen
Posted to MB Topic: Paradox Reports
55 days ago
1 Reply:

Steven.G
so.. the font isn't seen by paradox, but is seen by everything else ordinary font? unusual font? is anything else from the WP Suite installed? same issue?
55 days ago
Nothing New Since Your Last Visit
79
Hits

Thread 20 of 25
Thread Starter  

ForestCat
Export All Custom ObjectPal Code?
Hi, It's probably asking a lot, but is there some way to get a nicely formated (indented) document  listing all the ObjectPAL attached to a form?  Thanks for reading
Posted to MB Topic: ObjectPAL
64 days ago
2 replies. Last post:

Neil.N
 Thank you, Steven, that's awesome.  Of course I feel stupid that the capability is built in to the language itself and I didn't find it.  I was looking for it in the ui, but alas, it was burried in the 1000+ pages of paper manuals I got (and still have) w/ Borland Paradox For Windows in '93.  Ah those were the days ;-)
64 days ago
Nothing New Since Your Last Visit
95
Hits

Thread 19 of 25
Thread Starter  

PS_1789
Printing in Windows10
{Too Long!}
Posted to MB Topic: Paradox Setup, Vista, etc.
66 days ago
11 replies. Last post:

Steven.G
file/open the library program/compile file/save simple, and nothing will change.. but.. if the forms scripts and reports are all delivered (fdl not fsl, rdl not rsl, etc), you have to recompile EVERYTHING
65 days ago
Nothing New Since Your Last Visit
207
Hits

Thread 18 of 25
Thread Starter  

PS_291
PDOX11 over MSSQL (ODBC) - Schema in Table Names
Might anyone here know a way to configure ODBC/SQLEXPRESS under the BDE to return table names without a schema prefix (i.e., tablename rather than dbo.tablename)? Should I be looking at a different SQL DB?  Ideally, I’d like to point the alias that currently references the main paradox database to one referencing tables ported to sql and look at what needs fixing from there.  Thanks to a tool created and shared on codeproject by one of the forum members (thanks Igor!), database conversion to SQLEXPRESS went surprisingly easily, with only a few minor field type changes needed across hundreds of tables. I’m connecting to the SQL db fine from paradox via odbc. That said, I’ll consider a different back end (Firebird? PostgreSQL?) if it means the Paradox app will require fewer changes; I’m dealing with many forms and lots of code and porting the back end is a step toward a full conversion away from Paradox. Thanks! John
4 months ago
10 replies. Last post:

Steven.G
> The real surprise has been just how much has worked without major re-factoring < that is VERY cool
77 days ago
Nothing New Since Your Last Visit
263
Hits

Thread 17 of 25
Thread Starter  

GreatDivideIT
Could not initialize DBE - shared domain computer
{Too Long!}
Posted to MB Topic: Paradox Setup, Vista, etc.
98 days ago
1 Reply:

Steven.G
many possibilities, but most likely this profile is not accessing the shared files correctly, or the config in the BDE isn't the same
97 days ago
Nothing New Since Your Last Visit
123
Hits

Thread 16 of 25
Thread Starter  

coconut73
2003 server to 2016 server lock time out / slow
{Too Long!}
Posted to MB Topic: Paradox Setup, Vista, etc.
113 days ago
5 replies. Last post:

Jeff.R3
112 days ago
Nothing New Since Your Last Visit
173
Hits

Thread 15 of 25
Thread Starter  

Andrew.G
Adding Breakpoint causes Paradox to close
{Too Long!}
Posted to MB Topic: ObjectPAL
118 days ago
6 replies. Last post:

Steven.G
something to avoid? nothing that we know of.. computers aren't perfect.. stuff happens copy/paste? yes, that's what I've done.. I had to re-create a very complex form last year, for a client.. one piece at a time, test it, move on.. never found a specific piece that would fail.. eventually, it was all done, and I could finally make changes that they'd needed for several years
115 days ago
Nothing New Since Your Last Visit
199
Hits

Thread 14 of 25
Thread Starter  

lja
using alias to oracle, datamodel gives error
{Too Long!}
Posted to MB Topic: Paradox Forms
11 years ago
10 replies. Last post:

John.O2
{Too Long!}
119 days ago
Nothing New Since Your Last Visit
6061
Hits

Thread 13 of 25
Thread Starter  

rum
Table Corruption
{Too Long!}
Posted to MB Topic: Paradox Tables
4 months ago
4 replies. Last post:

Steven.G
{Too Long!}
4 months ago
Nothing New Since Your Last Visit
221
Hits

Thread 12 of 25
Thread Starter  

PS_291
LSL Dependency Problem - Pdox7 to Pdox11 Upgrade
{Too Long!}
Posted to MB Topic: ObjectPAL
21 months ago
9 replies. Last post:

John.O2
Cheers! If only the port away from pdox could go a easily, but hey- I'll take Win 10/Server 2019 compatibility in the meantime!
4 months ago
Nothing New Since Your Last Visit
860
Hits

Thread 11 of 25
Thread Starter  

Lothar.K
ObjectPAL version incompatable...?
Howdy, I run Paradox 9, under Win 10. I made a minor edit to a particular report. Let's call it Report1. Typically, I print that report using code that is on the doubleclick of a field on an MRO on a form called Form1. Now, when I launch Form1, and doubleclick on the appropriate field in the MRO, I get the error: "The objectPAL version used in this form is incompatible with this version of Paradox. You must recompile from source." So, I opened the form in Edit mode, viewed the code on the field's doubleclick, saved it, and delivered it. Next, I did just that for Report1. I relaunched Paradox, and also rebooted the system, but still get the error. In addition, I can launch the report, and can print it manually, with no problem. How can I correct this error when trying to use the code to do the printing from Form1? Sincere thanks, Lothar
Posted to MB Topic: ObjectPAL
4 months ago
2 replies. Last post:

Lothar.K
Hi Steven, I thank you for your suggestion and did try it. While experimenting, I stepped through the code, and found something odd, that allowed me to tweak it. With that, all worked well. So though I had success, I confounded the experiment, and I don't know which of the tweaks corrected things. In any case, as before, sincere thanks, Lothar
4 months ago
Nothing New Since Your Last Visit
149
Hits

Thread 10 of 25
Thread Starter  

GreatDivideIT
data threshold on reports?
My client closed a large amount of jobs in November and cannot generate reports. The error is '#Record_band is too big'. They are able to use the same report but for a different time period. For example, reports from Jan thru July work. Is there a setting we can change that will accommodate a larger dataset?  Thanks! Tim Albertson, Great Divide IT Consulting LLC, 2995 Skyline Blvd., Suite # 208, Reno, NV 89509, tim@greatdivideit.com, 775-229-4415 (direct), 775-636-5047 (mobile), 775-229-4398 (fax), www.greatdivideit.com
Posted to MB Topic: Paradox Reports
5 months ago
6 replies. Last post:

Steven.G
{Too Long!}
4 months ago
Nothing New Since Your Last Visit
205
Hits

Thread 9 of 25
Thread Starter  

leochaim
Paradox V8.0 on Windows 10 after Creators Update.
Does not start any more (PDXWIN32.exe). Only see a fast Flash of Paradox Initial Screen. Uninstalled and Instaled again, but still does not start. Other apps from the Corel WordPerfect Package. start Ok , On another PC with Paradox 10 it works ok after the Creators Update., Has anybody this problem?
Posted to MB Topic: Paradox Setup, Vista, etc.
25 months ago
50 replies. Last post:

Steve.M5
{Too Long!}
4 months ago
Nothing New Since Your Last Visit
8724
Hits

Thread 8 of 25
Thread Starter  

assure
OBJECT PAL WITH INTERBASE
hello , , I would Like to know where I find examples of Object Pal , , Thank you Big Grin!
Posted to MB Topic: ObjectPAL
17 years ago
8 replies. Last post:

Jim.S6
I think I found it. Its in Programs(x86)Paradox\Template\classic. At least all the database tables are there.  THANK YOU SOO MUCH
4 months ago
Nothing New Since Your Last Visit
2244
Hits

Thread 7 of 25
Thread Starter  

GreatDivideIT
"Could not open query file" error
Hi. About 7 users use Paradox in a shared environment. Today we saw a new error which we are having trouble resolving. We have backups. When the user opens a *.qbe using Paradox 11 the error is  "Cannot open : WORK:Invoice_Jobs Closed THIS year.qbe". Could not open query file. The same error dialog box reads "Do you want to replace: WORK:Invoice_Jobs Closed THIS Year.qbe in the". That message is truncated.
  • What can cause this error?
  • What files are necessary to restore? It seems there is a related *.rsl file and *.db file
  • What is the reference to "WORK:filename)? There is no WORK in the actual file name.
  • Some users access this file using an older version of Paradox. Those users see a different message: "Record_Band is too big to fit in report".
  • We don't do much Paradox support and have been directed here in the past. Any clues would be appreciated. Thanks! Tim tim@greatdivideit.com
    Posted to MB Topic: Paradox Reports
    5 months ago
    3 replies. Last post:

    Steven.G
    glad you figured it out.. a word of warning, tho.. in theory, one modified file does not necessarily require that you replace a whole folder.. you might be over-writing changed data that must be then replicated.. I would have replaced the qbe file only, at first
    5 months ago
    Nothing New Since Your Last Visit
    192
    Hits

    Thread 6 of 25
    Thread Starter  

    Lothar.K
    Debugger NOT Debuggin' (It's Blank...)

    Hello,

    I just entered a breakpoint in some code I have, but then, when I ran the code, the Debugger dialog launched, but it did not populate. It is completely blank.

    I have no idea how to proceed (but I do have a large mallet at the ready.)

    Thanks for any suggestions,

    Lothar

    Posted to MB Topic: ObjectPAL
    5 months ago
    4 replies. Last post:

    Lothar.K
    {Too Long!}
    5 months ago
    Nothing New Since Your Last Visit
    168
    Hits

    Thread 5 of 25
    Thread Starter  

    Sam.S
    Accessing an FTP with filesystem in ObjectPal
    {Too Long!}
    Posted to MB Topic: ObjectPAL
    26 months ago
    Nothing New Since Your Last Visit
    1672
    Hits

    Thread 4 of 25
    Thread Starter  

    GaryG
    Navigation buttons disabled
    I recently upgraded from Paradox 7 to Paradox 11.0.0.676. On one of the forms, the navigation buttons are disabled, yet I am able to scroll through the records using the wheel mouse. Any ideas on what may cause the navigation buttons to be disabled? P.S. I am new to Paradox. Thanks, Gary
    Posted to MB Topic: Paradox Forms
    6 months ago
    3 replies. Last post:

    Steven.G
    interesting.. two unrelated processes the last full version of paradox was v9 in 2000.. v10 in 2002 had a few minor additions.. v11 is v10 with the service packs added, and hasn't changed in 15 years
    6 months ago
    Nothing New Since Your Last Visit
    244
    Hits

    Thread 3 of 25
    Thread Starter  

    Shores
    Dreaded "Report layout settings have changed" msg
    Hello everybody, I hav a long running application of mine that has some reports (only landscape ones, as far as I can see) that have begun to show the dreaded message "Report layout settings (page size, paper orientation) have been changed"... Any hint on what can I do to make them behave properly again? I'm running PDX11 (X6 edition) and/or the latest Pdx Runtime 11... I've tried resetting the page size, both to printer specific page size (I'm in Italy so the standard page format is A4) and printer specific A4, to no avail. I've tried both the DynArray report.print and the ReportPrintInfo variant, they both do the same. I'm banging my head on the wall, but no idea seems to help! Thanks for any hint, Shores
    Posted to MB Topic: Paradox Reports
    6 months ago
    3 replies. Last post:

    Steven.G
    I resolved it by going back into the report spec and fixing it :-)
    6 months ago
    Nothing New Since Your Last Visit
    342
    Hits

    Thread 2 of 25
    Thread Starter  

    Shores
    Strange errors with :priv: report master table
    {Too Long!}
    Posted to MB Topic: QBE & SQL
    6 months ago
    3 replies. Last post:

    Steven.G
    if the path name is too long, doesn't matter which way you shorten it.. the printer name, you are best to actually be a shared printer, and shorten the network name
    6 months ago
    Nothing New Since Your Last Visit
    344
    Hits

    Thread 1 of 25
    Thread Starter  

    objectpal123
    Closing TCursor variables declared within a method
    If a variable that is declared within a method goes out of scope at the end of that method, is it really necessary to close a TCursor variable that is declared within a method?
    Posted to MB Topic: ObjectPAL
    7 months ago
    9 replies. Last post:

    Steven.G
    my job is to teach "best practice".. and allow for when it's not always worth re-engineering for, like in this situation.. your mileage may vary :-)
    7 months ago
    Nothing New Since Your Last Visit
    637
    Hits
    Follow PrestwoodBoards on: 


    ©1995-2019 PrestwoodBoards  [Security & Privacy]
    Professional IT Services: Coding | Websites | Computer Tech