I.T. Discussion Community!
-Collapse +Expand
Paradox
Search Paradox Group:

Advanced
-Collapse +Expand Paradox To/From
To/FromCODEGuides
-Collapse +Expand Paradox Store
PRESTWOODSTORE

Prestwood eMagazine

March Edition
Subscribe now! It's Free!
Enter your email:

   ► MB LobbyCorel Paradox / ObjectPAL Coding Board   Print This     

Paradox Reports Topic

 Show:
New Activity New Threads Oldest Unanswered Most Active Most Read
  


25 Threads:

Add New ThreadRandom Thread

Thread 25 of 25
Thread Starter  

gwatchmaker
Leap year date of birth
To all, I have a report that includes dates of birth when printed.  I have 4 digit year set as true in the BDE. For one particular dob (2/29/1996), the date of birth prints as 2/29/2996!  In the table, it is 2/29/1996.  This is a leap year birthday.  Although obviously not correct, it concerns my users. This report has printed tens of thousands of dates of birth and this is the first one they have noticed is wrong. Any thoughts? Greg
9 hours ago
New Stuff Since Your Last Visit
2
Hits

Thread 24 of 25
Thread Starter  

rum
Reports with Sub Reports
Anyone know If there is a way to add a subreport to a report?   This is not a Parent/child data issue.   Essentiall I need to cross tabulate data and give a summary of the report data by specific categories. Thanks
39 days ago
1 Reply:

Steven.G
I think you can put multiple table frames in the body.. historically, we've always done stuff like that by manually creating the text file for the report.. it's a ton of work, but then you can literally do anything you want
39 days ago
Nothing New Since Your Last Visit
27
Hits

Thread 23 of 25
Thread Starter  

PS_3060
Printing Error
I recently sent a project designed in P9 to friend and he is now using P11. He gets this error message when printing 1 type of report. The report is a multi page the error does not show in reports delivered in P11. Is there anyway I can get around this error without re devloping the report.  It is very tedious and time consuming report to design. Report: Layout settings(Page size,paper orientation) have been changed within the print dialog. This will require each page to be regenerated. This can take a long time for large reports. Do you wish to continue? Cheers Bill
70 days ago
1 Reply:

Steven.G
if you're using reportprintinfo to set up your print job, this might help repInfo.PanelOptions = PrintClipToWidth but that error can come from a variery of random sources.. sometimes you get that error, sometimes not
67 days ago
Nothing New Since Your Last Visit
39
Hits

Thread 22 of 25
Thread Starter  

afhynes2
Paradox 11 not printing to network printers
I have just re-installed my Paradox 11 on a Windowsx64 laptop and I cannot get it to print reports from Paradox reports themselves. However, they work perfectly if I call them up from a form in objectPAL. When I just try to print in a new Paradox sessionm I get a dialogue box that says: Printer interface setup error/ LCAppPrint Initialize failed!  Then Windows 10 just closes the program. I'm not all that good with finding out where my problem lies. Could anyone point me to some solution, please? Tony
43 months ago
11 replies. Last post:

Steven.G
most of the examples I can think of, for my recent apps, the print-to-pdf is being triggered manually.. but others are surely doing it in code, and I'm not seeing other instances of pdf failure being mentioned on the various forums also, Brother printers aren't so "standard" thesee days.. you never know....
81 days ago
Nothing New Since Your Last Visit
1811
Hits

Thread 21 of 25
Thread Starter  

SteveM
Printing Issue when migrating from Paradox 8 to 11
Greetings, We used a pushbutton method on a form to print a report in Paradox 8 and Windows 7.  Upon upgrading to Paradox 11 the report began failing with a "#Bitmap7 is too big to fit in report." error.
  • #Bitmap7 is a full-page 8.5x11 image
  • The error is printer independent, and fails even with a PDF printer
  • The report still works fine on any printer if you open the report and print directly from that
  • Shrinking the image and placing it in the middle of the page solved the problem too
  • Recucing the file size dramatically didn't help if left at 8.5x11
  • It must be that Paradox 11 is trapping an error based on image size that Paradox 8 didn't.  Is there any way to prevent it from doing this, or to tell the method to ignore the error and print anyhow? Might there be anything else obvious that I am missing? Thanks!
96 days ago
10 replies. Last post:

Steve.M5
{Too Long!}
88 days ago
Nothing New Since Your Last Visit
118
Hits

Thread 20 of 25
Thread Starter  

PS_3060
Fixed No of Rows in Table Frame
Is it possible to fix the number of rows in a MRO table frame even if only the first 4 or 5 are populated? I'm trying to make a complex form and report which fills the total area available.
6 months ago
1 Reply:

Steven.G
most anything you can change while editing a form, you can change by setting values when you open it.. you just need to find the right parameters to set fm.open(myform) fm.thistext = "Hello" fm.thisfield = "George" fm.wait()
6 months ago
Nothing New Since Your Last Visit
76
Hits

Thread 19 of 25
Thread Starter  

Paulo.C
Paradox stops running when I change printer
Hi! I have an application for driving school management, and on most computers where it is installed, from windows xp to 10, when I press a button to choose another printer, the paradox stops running. thank you for your support
19 months ago
5 replies. Last post:

Steven.G
> Probably I'll have to run this way, the problem is that in the printer interface the screen is all in English, and the application is in Portuguese. I got the notice that you posted this, but it does not show here yet if there is a language issue, that might be part of the problem.. can you insert little temporary msgInfo messages in the printing process, to see how far it gets? to determine the specific line it fails on?
19 months ago
Nothing New Since Your Last Visit
207
Hits

Thread 18 of 25
Thread Starter  

KBNV
Fonts in Win10 v1809
I just set up Paradox on a new system running the latest ver of Win 10 (1809).  My reports on the new system required a complete revision of the fonts used in the report.  I've been using the same ones for years and the fonts have always migrated to the new system.  This time, however, the fonts are not available in the properties, font drop down for any of the fields in my report.  The fonts are installed in the usual place and are available to the other myriad programs.  I installed Paradox from an X9 disc which I know doesn't make a difference.  I even uninstalled Paradox from the system and reinstalled using the X8 disc in the hope that it would make a difference.  It, of course, did not.  I am using other fonts that provide a similar impact.  But, not the same. Any body have any suggestions? Thanks in advance. Karen
24 months ago
3 replies. Last post:

Steven.G
find it, deleted it.. then kill the registry entries.. usually 3 or 4 of them
19 months ago
Nothing New Since Your Last Visit
328
Hits

Thread 17 of 25
Thread Starter  

LC.M
Printing with Office 365
Upgraded to Office 365 & got the LCAppPrint Initialized Failed error.  Installed the Hotfix Runtime patch after un/reinstalling Paradox 11.  Now, when i try to print, the program closes.    Any ideas are welcomed.  (Using Paradox for single user database & reports.)
21 months ago
3 replies. Last post:

Steven.G
external connectivity issues (printing, MAPI email, etc) can change with the versions.. p11 is the same, but the suite is different, , also, if you're using full paradox, a runtime patch isn't related to using that
21 months ago
Nothing New Since Your Last Visit
224
Hits

Thread 16 of 25
Thread Starter  

GreatDivideIT
data threshold on reports?
My client closed a large amount of jobs in November and cannot generate reports. The error is '#Record_band is too big'. They are able to use the same report but for a different time period. For example, reports from Jan thru July work. Is there a setting we can change that will accommodate a larger dataset?  Thanks! Tim Albertson, Great Divide IT Consulting LLC, 2995 Skyline Blvd., Suite # 208, Reno, NV 89509, tim@greatdivideit.com, 775-229-4415 (direct), 775-636-5047 (mobile), 775-229-4398 (fax), www.greatdivideit.com
27 months ago
6 replies. Last post:

Steven.G
{Too Long!}
26 months ago
Nothing New Since Your Last Visit
465
Hits

Thread 15 of 25
Thread Starter  

GreatDivideIT
"Could not open query file" error
Hi. About 7 users use Paradox in a shared environment. Today we saw a new error which we are having trouble resolving. We have backups. When the user opens a *.qbe using Paradox 11 the error is  "Cannot open : WORK:Invoice_Jobs Closed THIS year.qbe". Could not open query file. The same error dialog box reads "Do you want to replace: WORK:Invoice_Jobs Closed THIS Year.qbe in the". That message is truncated.
  • What can cause this error?
  • What files are necessary to restore? It seems there is a related *.rsl file and *.db file
  • What is the reference to "WORK:filename)? There is no WORK in the actual file name.
  • Some users access this file using an older version of Paradox. Those users see a different message: "Record_Band is too big to fit in report".
  • We don't do much Paradox support and have been directed here in the past. Any clues would be appreciated. Thanks! Tim tim@greatdivideit.com
    27 months ago
    3 replies. Last post:

    Steven.G
    glad you figured it out.. a word of warning, tho.. in theory, one modified file does not necessarily require that you replace a whole folder.. you might be over-writing changed data that must be then replicated.. I would have replaced the qbe file only, at first
    27 months ago
    Nothing New Since Your Last Visit
    439
    Hits

    Thread 14 of 25
    Thread Starter  

    Shores
    Dreaded "Report layout settings have changed" msg
    Hello everybody, I hav a long running application of mine that has some reports (only landscape ones, as far as I can see) that have begun to show the dreaded message "Report layout settings (page size, paper orientation) have been changed"... Any hint on what can I do to make them behave properly again? I'm running PDX11 (X6 edition) and/or the latest Pdx Runtime 11... I've tried resetting the page size, both to printer specific page size (I'm in Italy so the standard page format is A4) and printer specific A4, to no avail. I've tried both the DynArray report.print and the ReportPrintInfo variant, they both do the same. I'm banging my head on the wall, but no idea seems to help! Thanks for any hint, Shores
    28 months ago
    3 replies. Last post:

    Steven.G
    I resolved it by going back into the report spec and fixing it :-)
    28 months ago
    Nothing New Since Your Last Visit
    696
    Hits

    Thread 13 of 25
    Thread Starter  

    luckydogli
    report question
    Dear all,  I just got a paradox report on our legacy system - paradox 7 for windows. I need to find out what is the underlying data for the report. I opened the report in design mode and look at the data model. It has three tables, two of them linked. Two of them are priv table. I can find the two priv tables - one empty and the other one has data. how can I find which query makes the process? thanks for your help!
    33 months ago
    10 replies. Last post:

    Rulai.L
    Thanks Steven and rum, and this starts to make some sense now. I need to figure out this logic and re-write them in sql. 
    33 months ago
    Nothing New Since Your Last Visit
    834
    Hits

    Thread 12 of 25
    Thread Starter  

    rum
    Windows 10 (Creators update) Print issue
    I recently converted another user over to the Paradox 11 Runtime. I now have 10-12 users on the runtime This particular user is experiencing a strange error.  Any report that is sent directly to a Printer causes the runtime to crash.  Sending the same reports to the screen works,  but then subsequently attempting to print another crash Using a PDF Printer works without error. The printers are networked printers,  Paradox V8 on Win 10 had no problem printing to them. I have one other user with a similar problem,  in that users case, they are running Pdox11 runtime in a Remote Desktop environment,  They get the error if they are sending the job to a REDIRECTED printer.   If they send the job to a printer that is not redirected,  then the progam works correctly. Any thoughts?? Jeff
    43 months ago
    Nothing New Since Your Last Visit
    2063
    Hits

    Thread 11 of 25
    Thread Starter  

    MikeWA
    Passing Variables to Report
    I have a form which runs a query to select data within a specfied date range.  The form then opens a report based on the queried data.  Can I pass the start and end dates to the report in such a way as to display this range on the report?
    14 years ago
    Nothing New Since Your Last Visit
    3761
    Hits

    Thread 10 of 25
    Thread Starter  

    Jay.M
    Form Feed
    Dot matrix printer, printing invoices 8.5 x 11 ... after every invoice I get a formfeed (an empty invoice).. I have ran into this problem before and I believe what I have done is recreate the report and the problem goes away.  Anyone know how to fix this in a different and easier manner? This error only shows it ugly face after an edit to a well running report.  Out older epson took a dump and we bought a new oki 320 turbo 9 pin.. so I made some adjustments to the report to compensate to the printers start of form. This basically meant moving things up a bit. Grouped on order# with a table frame. report    page      group         all records         table frame ETC .. ETC..     
    40 months ago
    7 replies. Last post:

    Steven.G
    {Too Long!}
    40 months ago
    Nothing New Since Your Last Visit
    1098
    Hits

    Thread 9 of 25
    Thread Starter  

    Lothar.K
    Prints with Problem (but scrolls properly...)
    Hello, I have a particular mailing label report that just started to behave oddly: When I print the report, the result looks like this: GOOD LABEL 1, BLANK LABEL EJECTED, GOOD LABEL 2, BLANK LABEL EJECTED, GOOD LABEL 3, BLANK LABEL EJECTED, , To diagnose the problem, I viewed the report on screen, and it displayed LABEL 1. I clicked to view the next page, and expected to see a blank label, but instead, LABEL 2 appeared. As I clicked along, each label displayed in sequence properly, with no blank pages. So, when scrolling, all looks fine, but when printing, I get the alternation with blanks as I have described. What would be causing that situation, and how can I fix it? Many thanks, Lothar
    43 months ago
    4 replies. Last post:

    Jeff.R3
    Did any of the suggested solutions fix this.
    41 months ago
    Nothing New Since Your Last Visit
    752
    Hits

    Thread 8 of 25
    Thread Starter  

    Lothar.K
    Document Source Report broken...?
    {Too Long!}
    46 months ago
    4 replies. Last post:

    Lothar.K
    Hi Steve, When I read your comment, I thought "Of course... that would explain it." But, I searched with care, and there is no mention of "fldDate" in the code on the form. I'll try another approach and will get back here if I can't work it out. Many thanks, Lothar
    46 months ago
    Nothing New Since Your Last Visit
    881
    Hits

    Thread 7 of 25
    Thread Starter  

    Peter Dissing
    How To use a variable as the name for a report
    Hi I would like to have our delivery-note number as the report name, so when we print it with a PDF driver, the pdf attachement would have the same name as it corresponding deliverynote. In order words how would the syntax be for renaming the report before printing ?  Rgds Peter
    51 months ago
    2 replies. Last post:

    skalform
    Hi Bill We still are looking for an answer, so thank you for your reply. Yes, we do use PDF Creator.  So using file system method for renaming is the path.  Thank you.  Peter
    48 months ago
    Nothing New Since Your Last Visit
    1389
    Hits

    Thread 6 of 25
    Thread Starter  

    andwye
    Windows 7 Paradox 9 report crash
    I've successfully installed Paradox 9 on a windows 7 workstation linked to SBS 2008. However, when I went to amend a report by redefining a field, Paradox crashed. I've tried to do this on two different reports and on two different machines. Why would this happen? Does anyone know how to solve the problem?,
    11 years ago
    10 replies. Last post:

    Anonymous
    Great article , Apropos , if someone are interested in merging of two images , my friend merged a service here <a href="http://www.altomerge.com/" >ALTO-Merge</a> and also here http://pdf.ac/49I2EK. --- MAMMIE HAGINS
    6 years ago
    Nothing New Since Your Last Visit
    6843
    Hits

    Thread 5 of 25
    Thread Starter  

    Archana.P
    Report formatting issue.. please help
    Hi All, I am struglling to format 2 fields in RSL file. Can anybody pls tell how to group two fileds? so, always they appear on same line? Thank you.
    6 years ago
    Nothing New Since Your Last Visit
    1154
    Hits

    Thread 4 of 25
    Thread Starter  

    FlaglerMuseum
    Report vs Form size
    I'm having a bit of an issue with the window size of my reports and forms.  I want my forms to remain at the full size of the screen.  Under Form Data Properties I have checked off size to fit, I have several forms and when I open them they remain at full screen. The problem is that when I run reports they always come up a smaller screen size eventhough I have size to fit checked off under properties.  This wouldn't be much of a problem except for the fact that whenever I do open up a report not only does it shrink the report size but it shrinks the size of all the open forms, then after I close the report I have to maximize all my forms again.  This is driving me nuts as I run reports all day long.  Any suggestions? Thanks,  Teresa
    14 years ago
    3 replies. Last post:

    Anonymous
    Thoughtful post . Apropos , if your business wants a 1996 USDA VS 17-129 , my husband filled out a blank form here http://pdf.ac/a3CZL6. --- ISAURA RASCON
    6 years ago
    Nothing New Since Your Last Visit
    2061
    Hits

    Thread 3 of 25
    Thread Starter  

    OzPaul
    Calculated field and treat blank as zero
    First I should mention that I have "treat blanks as zero" ticked in settings of Pdx10 running on Win7 at work. On my report  I have numeric fields which are covered by undefined calculated fields that show a text value of "Absent" when the corresponding numeric value is 0.0. Otherwise the numeric value is shown. The problem is that when the field is left blank, I want a calculated field to show "Not Done". When I set up an iif isBlank() condition in a calculated field, the calculation treats the blank field as a 0 and reports 0.0 rather than "Not Done". It is as if the treat blank as zero over-rides the isBlank() request.... This does not seem right to me because  the underlying table value certainly is blank... Can you help? Regards. Paul
    7 years ago
    4 replies. Last post:

    OzPaul
    FYI, I have discovered that if I use the syntax fieldname = blank() rather than the isBlank() approach, then it works!
    7 years ago
    Nothing New Since Your Last Visit
    2893
    Hits

    Thread 2 of 25
    Thread Starter  

    afhynes2
    Setting up a report to use a specific paper tray
    I am relatively amateurish in developing applications, but have been doing it on and off for many years. I am setting up an application for my daughter's rural veterinary business that will store information about her business, clients and animals and which  will print invoices and statements of account for her clients. She runs Windows 7 operating system and has Corel Office X4 installed on a small network of two computers and two printers. My problem is that I want the invoices to print on her Lexmark T632 printer, which works okay, but I cannot find a way of telling the application to take the paper from Tray 2 on that printer. Is there some code I can write into the application that directs the report to a particular tray on the printer? Tony Hynes
    11 years ago
    2 replies. Last post:

    Anonymous
    Is there an option to declare paper type such as Letterhead? --- Jeff
    7 years ago
    Nothing New Since Your Last Visit
    3709
    Hits

    Thread 1 of 25
    Thread Starter  

    PaulHoran
    report problem
    {Too Long!}
    9 years ago
    1 Reply:

    Dan
    Hi Paul You are going to need to convert the numerical data to a string and append spaces to the right side of the string using the fill function.  If you want to convert the numerical field values into positional values you will probably have to resort to opal.
    9 years ago
    Nothing New Since Your Last Visit
    2490
    Hits

    New Thread

    Follow PrestwoodBoards on: 


    ©1995-2021 PrestwoodBoards  [Security & Privacy]
    Professional IT Services: Coding | Websites | Computer Tech